Unofficial Allis Homepage
Forum Home Forum Home > Allis Chalmers > Construction and other equipment
  New Posts New Posts
  FAQ FAQ  Forum Search   Events   Register Register  Login Login


1958 D Grader Hydraulics/Service

 Post Reply Post Reply
Author
Message
Snapper1 View Drop Down
Bronze Level
Bronze Level
Avatar

Joined: 18 Apr 2019
Location: Northern IL
Points: 6
Post Options Post Options   Thanks (0) Thanks(0)   Quote Snapper1 Quote  Post ReplyReply Direct Link To This Post Topic: 1958 D Grader Hydraulics/Service
    Posted: 25 Aug 2020 at 8:58am
Hydraulics on 1958 D grader are very slow/weak. Looking for service recommendations in Northern Illinois. Thanks
Back to Top
Sponsored Links


Back to Top
CAL(KS) View Drop Down
Orange Level
Orange Level


Joined: 18 Sep 2009
Location: Chapman, KS
Points: 3377
Post Options Post Options   Thanks (0) Thanks(0)   Quote CAL(KS) Quote  Post ReplyReply Direct Link To This Post Posted: 25 Aug 2020 at 9:06am
I would check the Hyd fluid strainer, it should at least have that, no filter unless someone added one. It could be plugged,  if that is clean you pump is probably worn out.
Me -C,U,UC,WC,WD45,190XT,TL-12,145T,HD6G,HD10W,HD16,HD20

Dad- WD, D17D, D19D, RT100A, 7020, 7080,7580, 2-8550's, R62, R72 HD15
Back to Top
Snapper1 View Drop Down
Bronze Level
Bronze Level
Avatar

Joined: 18 Apr 2019
Location: Northern IL
Points: 6
Post Options Post Options   Thanks (0) Thanks(0)   Quote Snapper1 Quote  Post ReplyReply Direct Link To This Post Posted: 25 Aug 2020 at 9:46am
I have the parts manual and do not see a strainer referenced. Where would it be located? If pump is worn out, can it be rebuilt? If not, thoughts on finding replacement? I did add hydraulic fluid to top off the tank.
Back to Top
CAL(KS) View Drop Down
Orange Level
Orange Level


Joined: 18 Sep 2009
Location: Chapman, KS
Points: 3377
Post Options Post Options   Thanks (0) Thanks(0)   Quote CAL(KS) Quote  Post ReplyReply Direct Link To This Post Posted: 25 Aug 2020 at 10:28am
I dont have first hand experience with a D grader, however most systems of that vintage did run a strainer,  would be located in the reservoir at the suction point.  It may be a small enough system that AC didnt bother, but My 1956 AC trackloader does.  Its likely the gear pump is simply worn enough that it wouldnt be rebuildable even if those parts were available which most likely are not.  you best bet is to find a replacement pump with the same mount and approximate size/flow.  if you have means to test pump pressure i would do that  before removing if possible.
  Hopefully someone with firsthand experience will chime in here...



Edited by CAL(KS) - 25 Aug 2020 at 10:29am
Me -C,U,UC,WC,WD45,190XT,TL-12,145T,HD6G,HD10W,HD16,HD20

Dad- WD, D17D, D19D, RT100A, 7020, 7080,7580, 2-8550's, R62, R72 HD15
Back to Top
DonBC View Drop Down
Orange Level
Orange Level
Avatar

Joined: 12 Sep 2009
Location: Courtenay, BC,
Points: 749
Post Options Post Options   Thanks (0) Thanks(0)   Quote DonBC Quote  Post ReplyReply Direct Link To This Post Posted: 25 Aug 2020 at 12:50pm
I had a 59 D grader and it did have a filter on the suction side between the tank and pump. The D grader hydraulics are a low pressure system. There are orifices in the two hydraulic valves for the blade lift control to slow movement for finer adjustment when grading. The pump is belt driven and it was hard to get the belts tight enough to prevent the belts from slipping and the pump stalling at times. I think the sheaves were worn from decades of slipping. I finally had an adapter made for the crankshaft pulley to direct drive the pump off the crankshaft which made a huge difference to the hydraulics.
Jack of all trades, master of none
Back to Top
Snapper1 View Drop Down
Bronze Level
Bronze Level
Avatar

Joined: 18 Apr 2019
Location: Northern IL
Points: 6
Post Options Post Options   Thanks (0) Thanks(0)   Quote Snapper1 Quote  Post ReplyReply Direct Link To This Post Posted: 27 Aug 2020 at 12:18pm
DonBC
I saw your 2010 post which included a picture of your adapter. The D grader I am working on was owned by my deceased brother and has sat for 8+ years. The hydro pump is only powered by a single v-belt which is likely the cause of weak hydraulics. Is it possible to get another adapter and do you recall where you obtained your coupler? Thanks
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.10
Copyright ©2001-2017 Web Wiz Ltd.

This page was generated in 0.094 seconds.


Help Support the
Unofficial Allis Forum