Unofficial Allis Homepage
Forum Home Forum Home > Allis Chalmers > Farm Equipment
  New Posts New Posts
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

1952 Allis-Chalmers B won’t start

 Post Reply Post Reply
Author
Message
Codeman1215 View Drop Down
Bronze Level
Bronze Level
Avatar

Joined: 15 Jun 2019
Location: Pennsylvania
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote Codeman1215 Quote  Post ReplyReply Direct Link To This Post Topic: 1952 Allis-Chalmers B won’t start
    Posted: 15 Jun 2019 at 1:18pm
So we rebuilt the carb with a new float. New spark plugs and cleaned the magneto points and button. We turn it over and there’s no fire. We’ve got fuel to the carburetor and a little spark from the magneto to the spark plugs, but when we take out the spark plugs, it doesn’t look like any fuel got there. We even tried spraying some fuel on the plug. Still nothing. We then took the exhaust off and we get puffs of smoke like it is giving fire. Could the carb float be a problem or do you think the Magneto isn’t giving off enough spark. The rotor button is pretty worn looking.
Back to Top
Sponsored Links


Back to Top
Sugarmaker View Drop Down
Orange Level
Orange Level
Avatar

Joined: 12 Jul 2013
Location: Albion PA
Points: 4811
Post Options Post Options   Thanks (0) Thanks(0)   Quote Sugarmaker Quote  Post ReplyReply Direct Link To This Post Posted: 15 Jun 2019 at 1:58pm
Codeman,
 Welcome to the Allis forum! Not a mag guy, so I will let others help you in that area. 
Pictures always help.
Regards,
 Chris
D17, WD45, WD,
Ford Jubilee, IH TD6
Many IH Cub Cadets
Back to Top
Alvin M View Drop Down
Orange Level
Orange Level


Joined: 24 Jun 2018
Location: PA
Points: 234
Post Options Post Options   Thanks (0) Thanks(0)   Quote Alvin M Quote  Post ReplyReply Direct Link To This Post Posted: 15 Jun 2019 at 2:41pm
Did You Check Mag Timing 
Back to Top
Codeman1215 View Drop Down
Bronze Level
Bronze Level
Avatar

Joined: 15 Jun 2019
Location: Pennsylvania
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote Codeman1215 Quote  Post ReplyReply Direct Link To This Post Posted: 15 Jun 2019 at 7:06pm
Do you have a link for the mag timing? All we lined up were the gears. In other words the dog ear tooth on the mag at the top and the tooth marked with an “S” on the cap at the bottom.
Back to Top
Gerald J. View Drop Down
Orange Level
Orange Level


Joined: 12 Sep 2009
Location: Hamilton Co, IA
Points: 5485
Post Options Post Options   Thanks (0) Thanks(0)   Quote Gerald J. Quote  Post ReplyReply Direct Link To This Post Posted: 15 Jun 2019 at 7:35pm
The shop manual may be helpful especially for details.
http://geraldj.networkiowa.com/Trees/Allis-Chalmers-G-B-C-CA-Service.pdf

And if its a Fairbanks Morse magneto I have a manual for it too:

http://geraldj.networkiowa.com/Trees/FM-Xmagneto.pdf

The magneto has to jump while cranking to get enough voltage for ignition.

Gerald J.

Back to Top
mdm1 View Drop Down
Orange Level
Orange Level
Avatar

Joined: 12 Sep 2009
Location: Onalaska, WI
Points: 1896
Post Options Post Options   Thanks (0) Thanks(0)   Quote mdm1 Quote  Post ReplyReply Direct Link To This Post Posted: 15 Jun 2019 at 8:46pm

Try this link. Really helped me get my 39 B going. http://rodnh.byethost12.com/?i=2
Everything is impossible until someone does it! WD45-trip loader 1947 c w/woods belly mower, 1939 B, #3 sickle mower 1944 B Misc other equipment that my wife calls JUNK!
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.10
Copyright ©2001-2017 Web Wiz Ltd.

This page was generated in 0.109 seconds.


Help Support the
Unofficial Allis Forum